Order problem????

Page 1 of 3 123 LastLast
Results 1 to 15 of 31
  1. #1
    Member


    Join Date
    Jul 2018
    Posts
    46

    Thanks Thanks Given 
    24
    Thanks Thanks Received 
    15
    Thanked in
    11 Posts
    Rep Points
    150100

    Order problem????

    Has this ever happened to anyone. All the times Iíve ordered international this has never happened. It seems like the order label was made, but it has never been dropped off to the mail facility. I ordered way before everything happened and now itís been since march 12 I ordered. Says shipped. Got tracking and always ready awaiting for item. Then I log in today and it says this. Am I about to take a loss or what. At this point Iíd just rather have my money back. First time ordering with Osgear and might be my last... Iíve been patiently waiting just to find out today thereís no package and even went on Usps and same thing. Any pointers. Has this happened to anyone and actually get your package or did you suffer a hard loss?? And what should I do from this point....




    Sent from my iPhone using Tapatalk

  2. #2
    Member


    Join Date
    Jul 2018
    Posts
    46

    Thanks Thanks Given 
    24
    Thanks Thanks Received 
    15
    Thanked in
    11 Posts
    Rep Points
    150100

    Quote Originally Posted by Mick View Post
    Did you email them about it first? Do they reship?
    Yes I did message them on the site. And they said to basically keep checking. That all planes are loaded with medical supplies. And that limited mail is going out. But my order never even made it to post office there to get shipped.


    Sent from my iPhone using Tapatalk

  3. #3
    Member


    Join Date
    Jul 2018
    Posts
    46

    Thanks Thanks Given 
    24
    Thanks Thanks Received 
    15
    Thanked in
    11 Posts
    Rep Points
    150100

    Quote Originally Posted by Mick View Post
    https://osgear.ws/faqs



    I would wait a little longer it is over the pond...
    Yea I know how it works overseas. But to have the label be created and for weeks checking to all of a sudden today say there is no item all of a sudden in red letters. Then checked Usps site and said same thing. Hoping got over looked and didnít make it to post office drop there or something. Never had this happen before with all the orders Iíve placed. I messeges them again with sites to check tracking to see what Iím saying and maybe contact the actual source i bought from them. We will see. If not I just want money back. Iíll stick with local. No more overseas. First time ordering with these guys. Everyone says orders came quick for them. Idk. Then I get the odd error message after weeks saying awaiting item after being created.


    Sent from my iPhone using Tapatalk

  4. #4
    Member


    Join Date
    Jul 2018
    Posts
    46

    Thanks Thanks Given 
    24
    Thanks Thanks Received 
    15
    Thanked in
    11 Posts
    Rep Points
    150100

    Iím guessing maybe ultima is having some kind of problems I just sent another email. Asking if maybe they can get my money back give me credit and get gear from another source on their page. Because this doesnít feel too comforting seeing this new update to tracking this late after ordering and supposably shipped.


    Sent from my iPhone using Tapatalk

  5. #5
    Senior Member
    suraonyx23's Avatar


    Join Date
    Feb 2015
    Posts
    3,912

    Thanks Thanks Given 
    1,628
    Thanks Thanks Received 
    816
    Thanked in
    578 Posts
    Rep Points
    2147483647

    Sources create labels all the time and donít actually use them. So to answer your question itís actually quite common. Yours could have been an honest mistake or could have been in order to buy the sponsor some time as Iíve seen that happen as well. Iím sure youíll get ur stuff

  6. #6
    Senior Member
    shawn4425's Avatar


    Join Date
    Sep 2019
    Posts
    657

    Thanks Thanks Given 
    44
    Thanks Thanks Received 
    374
    Thanked in
    267 Posts
    Rep Points
    8015342

    Shipped doesn't mean delivered. Its been 2 weeks on an International order. With all that's going on right now I'm extremely surprised you went this route. So not knowing Amy specifics of source or you, it seems you may ne waiting a while.

    Sent from my SM-G975U using Tapatalk

  7. #7
    Senior Member
    THEJOKER's Avatar


    Join Date
    Feb 2020
    Location
    Gotham
    Posts
    2,141

    Thanks Thanks Given 
    1,922
    Thanks Thanks Received 
    1,455
    Thanked in
    911 Posts
    Rep Points
    20963120

    Right now with an int order, give it 4wks min. Thatís what I would say. Wait, I actually did say that

  8. #8
    Member


    Join Date
    Jul 2018
    Posts
    46

    Thanks Thanks Given 
    24
    Thanks Thanks Received 
    15
    Thanked in
    11 Posts
    Rep Points
    150100

    Quote Originally Posted by shawn4425 View Post
    Shipped doesn't mean delivered. Its been 2 weeks on an International order. With all that's going on right now I'm extremely surprised you went this route. So not knowing Amy specifics of source or you, it seems you may ne waiting a while.

    Sent from my SM-G975U using Tapatalk
    I know shipped doesnít mean delivered. If you read what it says. In the pics it says carrier never got package. Only label created. So they never even dropped it off to carrier. And this was before coronavirus outbreak was bad and spreading. It was only in China at the time. Iíve ordered plenty of times international. And I know how it works. I have plenty of gear thatís why I ordered international. Cause I have the time to wait. But seeing the messages Iím getting now after weeks saying post office never got the item. Makes me wonder. But Iím going to go off the guy that posted before you and hope maybe thatís what happened.


    Sent from my iPhone using Tapatalk

  9. #9
    Member


    Join Date
    Jul 2018
    Posts
    46

    Thanks Thanks Given 
    24
    Thanks Thanks Received 
    15
    Thanked in
    11 Posts
    Rep Points
    150100

    I honestly donít think yíall understand whatís going on. Luckily I had this screenshot from before I got the new red letters saying item never received by carrier.

    This is what the tracking said for 2 weeks. And then after checking it everyday. After 2 weeks of get rest letters saying what I posted in the beginning. So post office is letting me know they never received it. So Iím doing everything I can to see whatís going on. Carrier never got package. Now the last two screenshots are from yesterday. This was yesterdayís update. So the first pic is what itís said for weeks. Then yesterday went to this. Label created, not in system. Carrier never got package after




    Sent from my iPhone using Tapatalk

  10. #10
    Senior Member
    suraonyx23's Avatar


    Join Date
    Feb 2015
    Posts
    3,912

    Thanks Thanks Given 
    1,628
    Thanks Thanks Received 
    816
    Thanked in
    578 Posts
    Rep Points
    2147483647

    Quote Originally Posted by Snookslayer05 View Post
    I honestly donít think yíall understand whatís going on. Luckily I had this screenshot from before I got the new red letters saying item never received by carrier.

    This is what the tracking said for 2 weeks. And then after checking it everyday. After 2 weeks of get rest letters saying what I posted in the beginning. So post office is letting me know they never received it. So Iím doing everything I can to see whatís going on. Carrier never got package. Now the last two screenshots are from yesterday. This was yesterdayís update. So the first pic is what itís said for weeks. Then yesterday went to this. Label created, not in system. Carrier never got package after




    Sent from my iPhone using Tapatalk
    Quote Originally Posted by Snookslayer05 View Post
    I honestly donít think yíall understand whatís going on. Luckily I had this screenshot from before I got the new red letters saying item never received by carrier.

    This is what the tracking said for 2 weeks. And then after checking it everyday. After 2 weeks of get rest letters saying what I posted in the beginning. So post office is letting me know they never received it. So Iím doing everything I can to see whatís going on. Carrier never got package. Now the last two screenshots are from yesterday. This was yesterdayís update. So the first pic is what itís said for weeks. Then yesterday went to this. Label created, not in system. Carrier never got package after




    Sent from my iPhone using Tapatalk
    I understand completely what is going on so please reread what I posted. I would almost guarantee you that ďa labelĒ was created but it wasnít your package. Thatís why the carrier never got the package because there was never one to begin with, just a throwaway label. But this doesnít mean that youíre not gonna get your stuff

  11. #11
    Member


    Join Date
    Jul 2018
    Posts
    46

    Thanks Thanks Given 
    24
    Thanks Thanks Received 
    15
    Thanked in
    11 Posts
    Rep Points
    150100

    Quote Originally Posted by suraonyx23 View Post
    I understand completely what is going on so please reread what I posted. I would almost guarantee you that ďa labelĒ was created but it wasnít your package. Thatís why the carrier never got the package because there was never one to begin with, just a throwaway label. But this doesnít mean that youíre not gonna get your stuff
    Thatís about all I can hope for. Guess time will tell.


    Sent from my iPhone using Tapatalk

  12. #12
    Senior Member
    SleevedOut's Avatar


    Join Date
    Jun 2013
    Posts
    160

    Thanks Thanks Given 
    1
    Thanks Thanks Received 
    22
    Thanked in
    13 Posts
    Rep Points
    301274064

    Hey guys, delete this if not allowed. But I tried to hide any important info. But I know how this dude feels. I dealt with the same thing bro. It saying the label was created, but that doesn't mean USPS has the package. But a week later, all of a sudden, it was in transit with a delivery date. It showed up a day before it was supposed to. Probably not the same company, but it's a USPS issue.

    Sent from my SM-N960U using Tapatalk

  13. #13
    Board Rep
    BOARD REP
    A.font401's Avatar


    Join Date
    Jan 2018
    Posts
    4,331

    Thanks Thanks Given 
    3,968
    Thanks Thanks Received 
    3,149
    Thanked in
    2,067 Posts
    Rep Points
    281203985

    I have one thatís been on itís way to the facility for about a month now.


    Sent from my iPhone using Tapatalk
    Local and International SARMS & Peptides

    Local and International AAS and HGH and much more only at P.S.L.

    PM me for questions or concerns ::HERE::

  14. #14
    Board Rep
    BOARD REP
    OSGear Rep's Avatar


    Join Date
    Oct 2019
    Posts
    135

    Thanks Thanks Given 
    110
    Thanks Thanks Received 
    64
    Thanked in
    50 Posts
    Rep Points
    2777649

    Quote Originally Posted by Snookslayer05 View Post
    Yea I know how it works overseas. But to have the label be created and for weeks checking to all of a sudden today say there is no item all of a sudden in red letters. Then checked Usps site and said same thing. Hoping got over looked and didnít make it to post office drop there or something. Never had this happen before with all the orders Iíve placed. I messeges them again with sites to check tracking to see what Iím saying and maybe contact the actual source i bought from them. We will see. If not I just want money back. Iíll stick with local. No more overseas. First time ordering with these guys. Everyone says orders came quick for them. Idk. Then I get the odd error message after weeks saying awaiting item after being created.


    Sent from my iPhone using Tapatalk

    Hi, I've answered you by PM regarding the delay in transit for all the packages during this global situation. Please be patient, there is nothing to be worried about... the package will arrive and also the tracking number will update as soon as will reach the US. The actual status that you're seeing until the package reach US is from the 'Origin' country... and here is a statement from them:

    "Delays in international shipments

    COVID-19 has severely impacted international movement of people and goods as countries implement additional border controls and restrictions on international travel. As a result, airlines have drastically reduced international services, leading to a significant reduction in air freight capacity and frequency to and from SG to all international destinations.

    Please note that there will be delays in the delivery of all international mail and Speedpost services to international destinations. We will be prioritising Speedpost Priority and Speedpost Express services during this period."

    Thank you.
    OSGEAR - YOUR TRUSTED ANABOLIC STORE!



  15. #15
    Board Rep
    BOARD REP
    OSGear Rep's Avatar


    Join Date
    Oct 2019
    Posts
    135

    Thanks Thanks Given 
    110
    Thanks Thanks Received 
    64
    Thanked in
    50 Posts
    Rep Points
    2777649

    Quote Originally Posted by Snookslayer05 View Post
    Thatís about all I can hope for. Guess time will tell.


    Sent from my iPhone using Tapatalk

    To eliminate any type of concern, your package was shipped and is currently in transit to your location. The tracking number is not fake or package not shipped. I would recommend to be patient and the package will arrive, very soon hopefully.

    Thank you.
    OSGEAR - YOUR TRUSTED ANABOLIC STORE!



Similar Threads

  1. Order problem
    By pumpedadmin in forum GrAnabolic
    Replies: 3
    Last Post: 02-10-2017, 09:14 AM
  2. problem with with my order with MFL
    By CRUMBS in forum Source Checking & Discussion
    Replies: 45
    Last Post: 09-18-2015, 06:51 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Copyright© 2012-2021 Anabolic Steroid Discussion Forums